Problems updating extensions

Securitycheck Control Center is able to update extensions which use the Joomla! Update. However, sometimes there are some errors during the update process and the task can't be accomplished. For instance, if we have an outdated version like this:

If we try to update it, we'll get an error:

If we try to update the extension using the Joomla! Update mechanism, we will know the reason:

We have done a great effort to test the maximum number of extensions using this mechanism. However, we can't test all extensions of the JED. Please, take note that many commercial extensions use its own update mechanism and they won't be able to be updated using the extension. If you find an extension which can't be updated, please write me an email to do some tests and add it to future releases.